Expired SSL certificate

Resolved
Operational
Started about 1 month ago Lasted 41 minutes

Affected

Updates
  • Resolved
    Resolved

    We renewed the SSL certificate and all systems are back to normal. We've set up reminders for SSL renewals to avoid this from happening in the future.

    What caused this?

    An SSL certificate had expired and took down our API domain.

    For any questions, please contact jascha.zittel@mercu.com

  • Identified
    Identified

    We identified an expired SSL certificate as the root cause. We renewed the certificate.

  • Investigating
    Investigating

    We're investigating why the web app and the team member UI aren't loading as expected.